Only Windows Internet Explorer Need Apply

November 23rd, 2008 | Tags: , ,

I thought that in 2008 we were past this crap:

Some web browsers are unable to display all site information correctly. This is most common on our site for MAC users that are using Internet Explorer as their browser. Our site is designed to work best on a Windows operating system, with Internet Explorer (version 5.0 or higher). If you are using something else, all of your account information may not be displayed correctly.

Just how hard is it to design a simple web page that works on more than a single browser?

No comments yet.
You must be logged in to post a comment.